Autor Tema: Fallo en mis inicios con PHP dentro de Html (AppServ)  (Leído 223 veces)

Desconectado ArisiaJordan

  • PHPerit@
  • *
  • Mensajes: 1
  • Karma: 0
  • Sexo: Femenino
  • Nuev@ PHPer@
    • Ver Perfil
Fallo en mis inicios con PHP dentro de Html (AppServ)
« en: 17 de Marzo de 2018, 11:58:03 am »
Hola, comunidad!
Soy nueva en esto de la programación, de hecho empecé el domingo a leer sobre Html, de ahí a MySQL y PHP, y tras toda la semana de lectura, hoy quería tener algo de satisfacción poniendo en práctica lo que yo asumía como muchos conocimientos acumulados, mis expectativas estaban por las nubes...

He creado un archivo .html dentro del que usaré lenguaje php; siguiendo las pautas que había leido, y al escribir esto que indico a continuación y cargar el archivo con mi navegador, cuál es mi sorpresa al ver que algo tan simple como mandar un mensaje con echo, no me funciona!. No sé si se debe a alguna configuración del lenguaje php contenida dentro del AppServ, que es la herramient que instalé, que parecía ser genial para alguien nuevo en el tema. Por supuesto, como no conozco detalles sobre esto, no he tocado nada de la configuración.
He leido un poco, intentando buscar la información con las palabras típicas de alguien que no sabe aún ni de lo que habla, jeje, y he leído que a veces está programado el php para usarlo con abreviatura (sólo <? al principio y ?> al final, pero nada. Bueno, he probado todo, con las comillas, sin comillas, con <p> antes del texto, sin él... el resultado sigue siendo el mismo. Bueno, vamos al lío, el archivo html contiene esto:
<!DOCTYPE html>
<html>
<head>
  <title>Primera página</title>
  <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
</head>
<body>
<?php
echo '<h1>Bienvendio a mi primera página</h1>';
echo "Esto es un completo desastre";
?>

</body>
</html>

Y en mi navegador se visualiza esto; tal cual sale aquí:
Bienvendio a la mi primera página'; echo "Esto es un completo desastre"; ?>

Pues nada, no me enrollo más, ahí dejo mi primera decepción por si alguien sabe decirme qué podría intentar para solucionarlo.
Pd: la <meta> que he puesto, la he buscado por ahí, porque tampoco me mostraba correctamente las palabras acentuadas, pero no creo que esté ahí el fallo puesto que si la quito, todo sigue igual.
Gracias de antemano.

Comunidad PHPeros

Fallo en mis inicios con PHP dentro de Html (AppServ)
« en: 17 de Marzo de 2018, 11:58:03 am »

Desconectado Ximenaz

  • PHPerit@
  • *
  • Mensajes: 2
  • Karma: 0
  • Nuev@ PHPer@
    • Ver Perfil
Re:Fallo en mis inicios con PHP dentro de Html (AppServ)
« Respuesta #1 en: 20 de Abril de 2018, 10:53:19 am »
What is the most important content within these websites? Are there more guidelines?

Desconectado anicasio

  • PHPerit@
  • *
  • Mensajes: 3
  • Karma: 0
  • Nuev@ PHPer@
    • Ver Perfil
Re:Fallo en mis inicios con PHP dentro de Html (AppServ)
« Respuesta #2 en: 07 de Agosto de 2018, 01:52:23 am »
No puedes utlizar codigo PHP dentro de un archivo con extension ".html" te recomiendo empezar primero con logica de programacion antes de continuar con PHP

necesitas crear tu archivo con extension .php de igual manera te recomiendo leer la documentacion de PHP cuando tengas dudas.